Minneapolis-Moline.com Forum Index Minneapolis-Moline.com
MinneapolisMoline
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 


Back to Minneapolis-Moline Homepage

Dash lights

 
Post new topic   Reply to topic    Minneapolis-Moline.com Forum Index -> Car Repair
View previous topic :: View next topic  
Author Message
MMJon



Joined: 15 Jan 2006
Posts: 13
Location: Manitowoc, WI

PostPosted: Wed Feb 15, 2006 1:17 am    Post subject: Dash lights Reply with quote

Having a problem with my daughter's dash lights. When her and her brother installed a "better" radio, it worked but no more dash lights..at all!! This is an 87 Ford Escort. We've replaced the headlight switch because the diagram shows all electrical coming from it. We've re-installed the radio and paid special attention to the mounting for grounds. No idea where, but I suspect that a ground has been lost between the under hood and the under dash. My next thought is to run a separate black wire from the ground side of battery to the metal parts of the dash to give a "good" ground. Any and all suggestions would be appreciated. Maybe one of you have run into this very thing and would be willing to share your discovery.
Thanks,
Jon
_________________
Smile, it make people wonder what you're up to!
Back to top
View user's profile Send private message
Jeff Hahn



Joined: 28 Nov 2005
Posts: 6
Location: Ithaca M I.

PostPosted: Wed Feb 15, 2006 8:36 pm    Post subject: dash lites Reply with quote

there should have originaly been a wire to the radio from the headlite switch.this wire will have voltage when the lites are on.voltage will be variable depending on position of dimmer switch.
there should also be a wire to the radio with constant voltage (headlites off&ignition switch off)this is for radio memory.
there should also be a wire from the ignition switch that will have voltage with ignition switch on&no voltage with switch off.
possibly the wire from headlite switch is connected to ground(could be grounded thru radio)or maybe a fuse is blown.
ford fuse boxes can be confusing on which fuse does what. i have seen 03 pickup not charging and found fuse for the rh driving lamp fuse the problem.
check all fuses but should be a5 or10 amp for dash lites.
will the dash lites work with new radio disconnected?
sorry i cant tell you what color wires should be.
hope this helps. jeff.
Back to top
View user's profile Send private message
MMJon



Joined: 15 Jan 2006
Posts: 13
Location: Manitowoc, WI

PostPosted: Wed Feb 15, 2006 11:35 pm    Post subject: Reply with quote

Only found 1 wire powering the radio. The fuses are all OK. I took them all out one at a time and checked with ohmeter. Then just to be sure tried new fuses in each. Removed a couple dash bulbs and checked them and they do work when powered, so it's not the bulbs. Still no dash lights. I hope to try the ground wire this weekend. I'll double check for extra power wires then. I'm open to any suggestions.

Thanks!
Jon
_________________
Smile, it make people wonder what you're up to!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Minneapolis-Moline.com Forum Index -> Car Repair All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group